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How to export premiere pro project to davinci resolve

In our last tutorial, in our look at learning DaVinci Resolve, we talked about the importing our Avid Media Composer timelines into Resolve for a roundtrip workflow, for color grading. Let’s now move on and talk about how Adobe Premiere Pro editors can utilize a similar workflow, to get their timelines into Resolve, as quickly and easily as possible.
Now, a couple of things I want to reiterate from our last lesson is that, first, you’'re going to want to only send a two channel audio wav file from Premiere over to Resolve, as you won’t need all of those layers bogging down your workflow. Your audio will only be a reference for you to make sure everything stays in sync for the round trip back to
Premiere. Next, since this is a round trip lesson, we’re assuming that you’ll be bringing your color graded timeline back to Premiere, when you’'re done, to do effects work/etc, so when you send your timeline to Resolve, it’s cuts and dissolves only. Alright, let’s get started! Once you have your Premiere timeline set to go, much like in Avid Media
Composer, AAF is the way to go, but the process in Premiere is much smoother. Simply navigate to “Export” in the File drop down menu, and select “AAF”. Once the AAF Export window opens, you can deselect everything. Yep, that’s right, everything. Simply click “OK”, and select where you want the AAF file saved to. Inside of Resolve, simply
navigate to the “File” drop down, and select “Import AAF, EDL, XML"”, and (for the most part), you can leave the “Load AAF” window on its defaults. Once you say “OK”, Resolve will import your AAF, and you’ll see your timeline all set to go! In our next article, we’ll wrap things up by looking at how the process works in Final Cut Pro X. [Updated
March 28, 2021, with a new intro.]For long-term archiving of any media project, I strongly recommend you export an XML version of every project you want to save - regardless of whether you use Adobe Premiere Pro or Apple Final Cut Pro.Project files are proprietary, XML files are designed for transfer and archiving. Protect yourself. EXECUTIVE
SUMMARYOne of the big, painful, lessons we learned with the demise of Final Cut Pro 7 was that it stored our edits in a proprietary format. Only FCP 7 could open FCP 7 project files. Once FCP 7 stopped working, we lost access to ALL our old edits. Not the media, but the edit.However, if we had simply exported our FCP 7 projects as XML, we could
access them today via Premiere or DaVinci Resolve or today’s Final Cut Pro.NOTE: As another example, Final Cut Pro X 10.0 projects are no longer readable by today’s Final Cut. But they would be if we had exported them as an XML file.The key point I'm making is that, regardless of the NLE we use, it is essential that we preserve our media and
edits for the future. And that means exporting a finished project as an XML file, as well as saving the original project file. XML files are designed for transferring files and data between applications. These text files are quite small, and readable by a wide variety of applications. This is because XML files do NOT contain media - they simply contain a
“pointer” to your media. This is the path and file name of where your media is stored. So, exporting an XML file does not preserve your media, it only points to it.If you open an XML file in the same application that created it, virtually all your project data should be safe. If you are moving XML files between applications from different developers,
media files, edits and dissolve transitions, for example, safely transfer while most titles and effects do not.Always archive your projects. The fastest and best way to open a project is to open the native project file. This preserves everything. But, for protection, also archive an XML of the same project. NOTE: Keep in mind - because it’s important - that
because XML does NOT contain media, you will need to archive media files separately. EXTRA RESOURCESHere’s a tutorial showing how to transfer projects from Final Cut Pro to Premiere Pro.Here’s a tutorial showing how to transfer sequences from Premiere to Final Cut Pro. EXPORT AN XML FILE FROM FINAL CUT PROHere’s a typical project in
FCP; though short, this can easily illustrate the export process. It contains video and audio clips, transitions, titles and captions.An XML (eXtensible Markup Language) file contains pointers to all clips, but not the actual media, as well as settings for just about everything in the project file.Select the project in either the Timeline or the Browser, then
choose File > Export XML. In the resulting dialog, give the XML file a name and storage location. Then, click OK.NOTE: Be sure to always pick the latest version of XML (Version 1.9 in this screen shot).In just a few seconds, an XML file is created. XML is a language similar to HTML that you see on many web pages, that explains exactly how the
project was created, but doesn’t contain any media. It just contains all the different settings applied to each clip.NOTE: For long-term archiving, I strongly recommend you save an XML version of every project you want to save. For example, we can convert FCP 7 XML projects easily today, but can’t convert a single FCP 7 project. XML is a long-term
archiving format.NOTE: XML files are just text files. You can open them with TextEdit and see what’s inside; for example the screen shot above is from my project. The good news is that you don’t need to understand how to read an XML file in order to use it.At this point, the XML file is complete and ready for archiving. EXPORT AN XML FILE FROM
PREMIERE PROHere’s a typical project in Premiere. Note that it has audio and video clips on multiple tracks, transitions, and titles. While this is a short sequence it will serve to show how the export process works.Select the sequence you want to export. NOTE: You can, if you want, export an XML file of the entire Premiere project. However, I tend to
export the specific sequences that I need.Choose File > Export > Final Cut XML.First, Premiere simplifies the XML associated with this sequence, then opens a dialog where you can give the XML file a name and storage location.NOTE: I tend to store XML files on the desktop while I am working with them, to make them easier to find, then move
them into a dedicated location after the export is complete. This isn’t required, it’s just how I work.Premiere generates, then exports an XML file to the location you specify.Next, it creates a Translation Report of anything that won’t successfully translate.Here’s what the Translation Report looks like for this sequence. Your Report will look different,
depending on the contents of your sequence.At this point, you can quit Premiere Pro CC. We are done with it.The last step is to find a safe home to store your XML files. Oh! And be sure to give them a file name that allows you to find them again in the future. Bookmark the permalink. When it comes to learning how to export in DaVinci Resolve, there
are a few simple steps that you need to know. This will be useful whether you’re just learning the ropes as a video editor, or you're well-seasoned in the field, and you’re getting to grips with DaVinci Resolve as a post-production software.In this tutorial, you’ll learn how to identify the settings that you need to take your project from a DaVinci Resolve
timeline to a video that you can share, publish, or send to clients. It’s really simple once you know how. When you’ve got the hang of the basics, there are even a few more advanced tips to help with your more specific exporting woes. Part 1: How to Export in DaVinci ResolveFirst of all, you need to know the basics of how to export your video. Think of
your edited video like a mixture of ingredients in a bowl; it won’t be ready to share—or “enjoy”, in this analogy— until you’ve “baked” it. That’s where the process of rendering your clips through the export comes in. There are a few settings you can choose to do this in, but here are the basic principles.Step 1: The Deliver TabOnce you're in the Deliver
tab, make sure you understand the basics of which area will carry out which function. That way, you can know what you need to do to have better control over your final product.Click on the Deliver tab on the bottom bar of DaVinci Resolve.You can see your timeline at the bottom of the window. Remember that in the Deliver tab, you’ll be unable to
change the order of your clips.Your Preview viewer is in the middle of the window.The top left column is where you will make changes to the settings of your video before you export it. These are your Render Settings.The top right column in your Render Queue, where you can see how many timelines are in line to export.You can show or hide the
selected clips by pressing the Clips button on the top left toolbar.Step 2: Video Export SettingsYou have a lot of control over your custom export settings for a reason. There are settings available for any type of video you may want to export. You'll look more into some of the presets readily available below, but for now, you will learn how to export a
high-quality video in a relatively small file.Enter what you want your file to be called in the File Name field.Choose your file destination by clicking the Browse button next to the location field, and navigate to the folder where you want your final video to be saved.Select Single Clip to make sure your final export is one single video clip, rather than
many from all of the edited clips that make up your video.Make sure the Export Video box is checked unless you are exporting audio only.Select Quicktime or MP4 from the Format dropdown menu.Leave your Codec as H.264.Leave your Resolution and Frame Rate to match your project settings.If you want to export a different resolution such as
square or vertical, select Custom next to Resolution, and enter your desired orientation in pixels.You can leave your export quality on Automatic. If you're trying to limit your file size, try selecting Restrict to and lower your bitrate (Kb/s).You can leave the rest of the options on their default settings.Step 3: Render Your ProjectClick on add to Render
Queue. Your project will appear on the list in the workspace on the right of your screen.You can queue up several versions of your project for export. Go back and edit their settings by clicking on the pencil icon next to their title in the Render Queue.Click on Start Render when you want the exports to begin.For some more in-depth knowledge, here’s
a great tutorial for rendering in DaVinci Resolve.Part 2: Pro Tips & TroubleshootingThe Delivery tab may seem a little confusing at first. Once you get the hang of it, you’ll realize that there’s not that much more to it than what you’'ve learned today. Although there are a few eventualities you may want to learn how to manage in advance.Slow exports
is one problem a lot of people run into. There are a huge variety of things that could affect your export time, including the number of programs you are running at the time, and how much space is available on your computer. If you don’t mind losing a little bit of quality, you can also try reducing the bitrate (the Kb/s setting under the Quality heading
of your export settings) or Resolution of your video to see if it helps with your export time. In addition to long export times, here are some other tips that could help you out when exporting your DaVinci Resolve project.1. Export Your Project for Further CollaborationSometimes you may need to export your DaVinci Resolve project as a project rather
than a video. This allows you to continue to work on it on another computer or pass it to a collaborator. To do this, you need to export your project as a .drp file.Open your desired project.Click on File > Export Project.Select the location you want to save your file. It will automatically save as a .drp file.2. Export PresetsLet’s take a moment to look at
some of the available export presets made available by DaVinci that you may find useful in your workflow.The YouTube preset is available in 720p, 1080p, or 4K resolution. Choose this option if you quickly want a file that’s compatible with a YouTube upload.The Vimeo preset is also available in 720p, 1080p or 4K. Its settings are similar to the
YouTube template.ProRes is a format where the final file is minimally compressed. Many editors export in Prores to have a high-quality copy of their final work, or as an intermediate file to pass to their colorist, for example, when they have finished editing their video since the large file retains a lot of data.H264 is the standard video compression for
most online video, and H265 is its successor.Premiere Pro, Avid and Final Cut Pro presets will let you export your project into a new timeline that is compatible with each respective software.3. Create Your Own PresetDaVinci also lets you save your export settings as your own preset to speed up your workflow in the future.Set your desired custom
export settings.Click on the icon of three small dots in the top right corner of your Render Settings space.Select Save as New Preset.Your new preset will appear in the toolbar with the other ready-made presets.4. Exporting with SubtitlesIf you have Subtitles, go to the Video tab and scroll down to Subtitle Settings.Check the Export Subtitle
box.Choose from the dropdown menu whether you would like your video exported as a Separate File (such as an SRT file) or to Burn into Video.5. Export Sections of Your ProjectDaVinci Resolve will export your whole timeline by default, but you can also choose to export only part of your timeline.Before you add your project to the Render Queue,
click and drag your timeline Playhead to where you would like your exported clip to begin.Press your i key to set your in point (where the clip will start).Position the Playhead where you want your export to end, and click the o key to set your out point.Add your project to your Render Queue as normal.6. Export with an Alpha ChannelOften times, you’ll
want to export a piece of footage or title with a transparent background to use in another project or share to another NLE. You can do this by exporting with an alpha channel and we’ll take you through how to do that in this tutorial. Now that you know the basics of how to export in DaVinci Resolve, you can see that it’s not so intimidating after all.
There are a lot of options which can seem overwhelming, but you’ve already learned how to deal with many of them. The good news is that DaVinci Resolve is a powerful tool, so some of the advanced settings don’t need to be touched unless you need a high level of control over a bigger project.So now, there’s really nothing to hold you back from
sharing your projects with your collaborators, clients, and the world! In the first episode of our color grading tutorial series, we covered basic fundamentals in Adobe Premiere. Now, we’re going to show you how to incorporate DaVinci Resolve, a professional color grading tool, into your Adobe Premiere editing workflow.Here’s how to make the round
trip from Adobe to DaVinci and back more seamless and less error-prone. These tips take the guesswork out of the color grading process.Video TutorialJoin Nick LaClair, head of video production at SproutVideo, as he shows the entire end-to-end process for color grading with Adobe Premiere and DaVinci:If you liked that episode, be sure to catch the
rest of our How To Video series! Subscribe to our newsletter to get each episode, plus other video-focused tips and trends.When to Use DaVinciDaVinci is most appropriate for advanced color grading needs. As a professional color grading tool, it allows you to make changes to your video’s visuals with a high level of accuracy and control. Since it’s a
color managed application, you can be sure your final rendered output will look the same to your viewers on the web as it does on your computer.When your video is edited down to a final cut, it’s time to color grade! This should be close to the very last step in your process, if not the last step. Color grading can be a lengthy, involved process, and it’s
best to do it all in one go.Here is an overview of the process to send your footage from Premiere to DaVinci, and reimport it to Premiere to finalize your video. Follow these exact steps to avoid common pitfalls along the way.1. Preparing to Send Your Project to DaVinciThe process starts in Adobe Premiere. First, you’ll want to duplicate your video
project to create a version you can import into DaVinci. This allows you to make changes without potentially losing any prior work from the editing process.Then, remove the audio track, flatten your sequence, and remove any attributes, like effects. This will leave you with a clean sequence ready for editing in DaVinci.Prior to importing the XML from
Adobe to DaVinci, make sure your video clips will be formatted correctly in DaVinci. Under File > Project Settings, select Image Scaling and make sure it’s set to “Center Crop with No Resizing”.Finally, check your timeline’s color space to ensure your video will appear the exact same in DaVinci as it will to your viewers on the web. Under Color
Management, change your color settings to sRGB.Additionally, if you really want to see the real world version of your video colors, you’ll need a calibrated monitor that allows you to use RGB color space. If one isn’t available to you, you can still make accurate color changes in DaVinci as long as your color space settings are set to sRGB.2. Editing in
DaVinciNow, you're ready to import your timeline to DaVinci for color grading.Navigate to File > Import Timeline > Import XML. Select the duplicated XML file we created earlier.Leave the import options set to the defaults, and DaVinci will import your timeline just as it appears in Premiere.You’'re now ready to color grade in DaVinci! Navigate to
the Color tab at the bottom, and make any needed adjustments to your video. We’'ll cover exactly how to do that in our upcoming episode next week.3. Exporting Back to PremiereAfter completing your color adjustments in DaVinci, you're ready to send your footage back to Premiere. Here’s how to optimize your settings during that process.Go to the
Delivery tab, and at the top, choose Premiere XML. Select an empty folder for your final output, and under Render Settings, uncheck audio since this file contains no audio.The result will be all of your individual clips rendered as an XML file with the new color grade. Once rendered, you’ll be ready to rebuild your timeline in Premiere.However, one
extra step can save you a lot of headaches down the road. If you find you need to make some small edits in the future, such as adding a half second here or there, you’d need to redo the entire process. Or, you can simply tell DaVinci to include a little extra footage when it renders your clips.To do that, go to Advanced Settings, and select the option to
Add Frame Handles. Typically, Nick adds 24 frame handles, which adds an extra second of footage to both sides of your clip.You’'re now ready to render your footage. Click, “Add to Render Queue.”Then, on the right hand side of the screen, click, “Start Render.”Putting it all TogetherBack in Premiere, create a new folder called “Color Grade”.Select
that folder, then go to File > Import, and locate the rendered files from DaVinci. You’ll see all the individual clips, as well as an XML file. Select the XML file, and click Import.Once the XML is imported into Adobe Premiere, open the new color graded timeline, and copy the new sequence over to your original edited version.Now that your color graded
footage is back in Adobe, your project is ready to be exported and shared with the world! We hope these tips helped take the guesswork out of color grading with professional tools like DaVinci Resolve and Adobe Premiere.Burning questions about color grading? Add a comment below for expert advice.If your video is ready to go, start sharing your
picture-perfect footage today with a free 30 day trial of the SproutVideo platform!
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